MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005124AContentImport/Exportpublic2012-12-13 15:502013-03-15 10:53
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0005124: Export CC QTI Fail
DescriptionWhen CC is exported, with multiple choice test questions, the respcondition section of the QTI xml file is not appended. It would appear the $numchoices is not being set. See getChoices() in include/classes/testQuestions.class.php, passed to the M/C QTI template default/tests/test_questions/multichoice_qti_1p2.tmpl.php
Steps To Reproduce<?php for ($i=0; $i < $this->num_choices; $i++): ?>
                    <?php if ($this->row['answer_'.$i]): ?>
                <respcondition title="CorrectResponse">
                    <conditionvar>
                        <varequal respident="RESPONSE<?php echo $this->row['question_id']; ?>">Choice<?php echo $i; ?></varequal>
                    </conditionvar>
                    <setvar varname="que_score" action="Set"><?php echo (isset($this->row['weight']))?$this->row['weight']:1; ?></setvar>
                </respcondition>
                    <?php endif; ?>
                <?php endfor; ?>
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005894)
cindy (administrator)
2012-12-14 14:58

Commit#: ac6ee8a8506c3ed23ced5cc34868a826c5406e70

Solution: The cause of this issue is, when importing a common cartrige that contains multiple choices questions, the answers for those questions are not imported in.

Affected script: include/classes/QTI/QTIParser.class.php
(0006220)
greg (administrator)
2013-03-15 10:53

resolved in AContent 1.3

- Issue History
Date Modified Username Field Change
2012-12-13 15:50 greg New Issue
2012-12-13 15:50 greg Status new => assigned
2012-12-13 15:50 greg Assigned To => cindy
2012-12-14 14:58 cindy Note Added: 0005894
2012-12-14 14:58 cindy Status assigned => resolved
2012-12-14 14:58 cindy Resolution open => fixed
2013-03-15 10:49 greg Fixed in Version => 1.3
2013-03-15 10:53 greg Note Added: 0006220
2013-03-15 10:53 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker