MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005187ATutorMultiSitepublic2013-02-05 10:482013-02-20 11:14
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.1.1Fixed in Version2.1.1 
Summary0005187: subsite theme images
DescriptionThe sidemenu toggles are genrated from from jscripts/ATutorCourse.js, needs the image path updated to reflect the new theme structure.
Steps To ReproduceFor now I will copy the missing images from the aionline theme into the ATutor primary images directory
TagsNo tags attached.
Affects versionSVN
SVN Revision#f83a22f7e6dc18f6a73e2f2e03278ef75e5c2f19
Attached Files

- Relationships
duplicate of 0005182closedcindy sequence/side menu toggles in customized themes 
related to 0005164closedgreg Import Theme Multisite 

-  Notes
(0005952)
greg (administrator)
2013-02-05 10:52

Same issue for hide/show side menu toggle, same file
(0005978)
cindy (administrator)
2013-02-08 14:04

Solution: defines a constant that calculates the customized data directory by checking if the current theme is customized. This directory is:
For the main site: [ATutor-root]
For the Subsites: [ATutor-root]/sites/[Subsite-URL]/

Affected scripts:
include/header.inc.php
include/vitals.inc.php
jscripts/ATutor_js.php
jscripts/ATutorCourse.js
(0005980)
greg (administrator)
2013-02-10 09:00

The fix for subsite related images in custom themes appears to break those images in the standard themes.
(0006054)
cindy (administrator)
2013-02-12 09:59

Solution: Use complete URLs for the theme images on the webpage to bypass the base href.

Affected: include/vitals.inc.php
(0006084)
greg (administrator)
2013-02-20 11:14

resolved in 2.1.1

- Issue History
Date Modified Username Field Change
2013-02-05 10:48 greg New Issue
2013-02-05 10:50 greg Category Theme => MultiSite
2013-02-05 10:52 greg Note Added: 0005952
2013-02-05 11:39 greg Assigned To => cindy
2013-02-05 11:39 greg Status new => assigned
2013-02-05 13:53 greg Relationship added duplicate of 0005182
2013-02-05 13:55 greg Relationship added related to 0005164
2013-02-08 14:04 cindy SVN Revision# => 6e0cca6b3215a3d174c8676c7d37dfb73c92439e
2013-02-08 14:04 cindy Note Added: 0005978
2013-02-08 14:04 cindy Status assigned => resolved
2013-02-08 14:04 cindy Fixed in Version => 2.1.1
2013-02-08 14:04 cindy Resolution open => fixed
2013-02-10 09:00 greg Note Added: 0005980
2013-02-10 09:00 greg Status resolved => new
2013-02-12 09:59 cindy SVN Revision# 6e0cca6b3215a3d174c8676c7d37dfb73c92439e => f83a22f7e6dc18f6a73e2f2e03278ef75e5c2f19
2013-02-12 09:59 cindy Note Added: 0006054
2013-02-12 09:59 cindy Status new => resolved
2013-02-20 11:14 greg Note Added: 0006084
2013-02-20 11:14 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker