MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005193ATutor- no cat -public2013-02-12 11:152013-02-20 11:14
Reporteranovak 
Assigned Toanovak 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target Version2.1.1Fixed in Version2.1.1 
Summary0005193: SQL language_pages table inconsistencies
Descriptionterm column is VARCHAR(30) in language_pages
term column is VARCHAR(50) in language_text

This difference breaks page caching as well as generates lots of faulty INSERT statements for language_pages table in _AT() function.
Also this should create lots of troubles for translators who want to translate existing terms.

page column is VARCHAR(50) in language_pages
Since some of the ATutor page addresses are longer than 50 characters it breaks page caching. Also this should create lots of troubles for translators who want to translate existing terms.

SOLUTION:
Both term columns should have the same length in both tables.
page column should be big enough to accomodate different variation of ATutor page addresses.
TagsNo tags attached.
Affects versionSVN
SVN Revision#https://github.com/atutor/ATutor/pull/43 [^]
Attached Files

- Relationships

-  Notes
(0006083)
greg (administrator)
2013-02-20 11:14

resolved in 2.1.1

- Issue History
Date Modified Username Field Change
2013-02-12 11:15 anovak New Issue
2013-02-12 11:16 anovak Summary SQL table inconsistencies => SQL language_pages table inconsistencies
2013-02-12 14:04 anovak SVN Revision# => https://github.com/atutor/ATutor/pull/43 [^]
2013-02-12 14:04 anovak Assigned To => anovak
2013-02-12 14:04 anovak Status new => assigned
2013-02-12 14:04 anovak Fixed in Version => 2.1.1
2013-02-12 14:04 anovak Status assigned => resolved
2013-02-12 14:04 anovak Resolution open => fixed
2013-02-20 11:14 greg Note Added: 0006083
2013-02-20 11:14 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker