MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005437ATutorGlossarypublic2014-01-22 02:402016-01-02 14:49
Reporterayushguptadtu 
Assigned Togreg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.3 
Target VersionFixed in Version2.2.1 
Summary0005437: words containing aprostrophe required '/' in glossary
DescriptionIn glossary manager, while adding a new glossary term
when I entered a word baker's, it displayed an error "ATutor was unable to access the database."
but when I added a backword slash baker/'s , it accepted it and displayed as baker's
Steps To Reproducego to manage > add glossary term
enter any word containing apostrophe
click save
TagsNo tags attached.
Affects version2.0.3
SVN Revision#05dc6bd..d6de4fd
Attached Filespng file icon glossary_error.png [^] (23,151 bytes) 2014-03-02 12:42

- Relationships
duplicate of 0005428closedgreg Apostrophies in gloassary terms 

-  Notes
(0006696)
ayushguptadtu (developer)
2014-01-23 09:34

I have created a pull request for the issue (https://github.com/atutor/ATutor/pull/86 [^])
(0006700)
greg (administrator)
2014-03-02 12:46

The two words hown in the screen shot above should not appear with the [?] tags around them. They should be dashed unerlined, and when a mouse pointer hovers over them, a tooltip opens. Create a glossary items without an apostrophy to see what it should look like
(0007193)
greg (administrator)
2016-01-02 12:41

added preg_replace() to escape apostrophies in glossary terms
(0007212)
greg (administrator)
2016-01-02 14:49

closed for ATutor 2.2.1

- Issue History
Date Modified Username Field Change
2014-01-22 02:40 ayushguptadtu New Issue
2014-01-23 09:34 ayushguptadtu Note Added: 0006696
2014-03-02 12:42 greg File Added: glossary_error.png
2014-03-02 12:46 greg Note Added: 0006700
2014-05-15 18:27 greg Relationship added duplicate of 0005428
2016-01-02 12:41 greg SVN Revision# => 05dc6bd..d6de4fd
2016-01-02 12:41 greg Note Added: 0007193
2016-01-02 12:41 greg Status new => resolved
2016-01-02 12:41 greg Fixed in Version => 2.2.1
2016-01-02 12:41 greg Resolution open => fixed
2016-01-02 12:41 greg Assigned To => greg
2016-01-02 14:49 greg Note Added: 0007212
2016-01-02 14:49 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker