MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005450ATutorImport Contentpublic2014-05-14 19:212014-07-08 18:02
Reportergreg 
Assigned Tocindy 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.2Fixed in Version2.2 
Summary0005450: QTI Import Fails mysqli
DescriptionSeems to be related to the test_question_queries.inc.php's AT_SQL_TEST and the query run in QTIImport.class.php, failing to import into the tests table.
Steps To Reproduce[14-May-2014 19:14:45] INSERT INTO AT_tests_questions VALUES ( NULL, 0, 27, 2, 'Correct answer. False, justified text can be difficult to read for some people with print disabilities', 'Text justification should be used to make text easier to read.',
                            '', '', '', '', '', '', '', '', '', '',
                            2, 0, 0, 0, 0, 0, 0, 0, 0, 0,
                            '', '', '', '', '', '', '', '', '', '', 5, 0, 'DEFAULT')
[14-May-2014 19:14:45] PHP Warning: vsprintf(): Too few arguments in /var/www/sites/multi2.atutorspaces.com/include/lib/mysql_connect.inc.php on line 148
[14-May-2014 19:14:45]
[14-May-2014 19:14:45]
[14-May-2014 19:14:45] INSERT INTO AT_tests_questions_assoc(test_id, question_id, weight, ordering, required) VALUES (0, 230, 5, 1, 0)
TagsNo tags attached.
Affects versionSVN
SVN Revision#20a350c21f23b4baf269e30f0583a52b6559fb0d
Attached Fileszip file icon Understanding_Web_Accessibility-Unit_1_Quiz__Perceivable-20140514.zip [^] (5,354 bytes) 2014-05-14 20:00
zip file icon Understanding_Web_Accessibility_-_Principle_1__Perceivable_imscc.zip [^] (506,632 bytes) 2014-05-14 20:18

- Relationships

-  Notes
(0006746)
greg (administrator)
2014-05-14 20:03

$msg->containsErrors() is true line 261 QTIImport.class.php, so the above mentioned AT_SQL_TEST does not even run.
(0006747)
cindy (administrator)
2014-05-16 15:32

Fixed issue by escaping the special character % in SQL values before the SQL reaches queryDB() since vprintf() used in queryDB() needs % specifically for wildcard searches.

The escaping is added for inserting tests and content records.
(0006748)
greg (administrator)
2014-05-16 16:44

Commit by cli, created function to escape "%" in any data entering the db.
(0006804)
greg (administrator)
2014-07-08 18:02

Closed prior to ATutor 2.2

- Issue History
Date Modified Username Field Change
2014-05-14 19:21 greg New Issue
2014-05-14 20:00 greg File Added: Understanding_Web_Accessibility-Unit_1_Quiz__Perceivable-20140514.zip
2014-05-14 20:03 greg Note Added: 0006746
2014-05-14 20:05 greg Assigned To => cindy
2014-05-14 20:05 greg Status new => assigned
2014-05-14 20:18 greg File Added: Understanding_Web_Accessibility_-_Principle_1__Perceivable_imscc.zip
2014-05-16 15:32 cindy Note Added: 0006747
2014-05-16 16:44 greg SVN Revision# => 20a350c21f23b4baf269e30f0583a52b6559fb0d
2014-05-16 16:44 greg Note Added: 0006748
2014-05-16 16:44 greg Status assigned => resolved
2014-05-16 16:44 greg Fixed in Version => 2.2
2014-05-16 16:44 greg Resolution open => fixed
2014-07-08 18:02 greg Note Added: 0006804
2014-07-08 18:02 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker