MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005510ATutorInstallationpublic2014-08-21 10:022016-01-06 14:21
Reportercindy 
Assigned Togreg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2.1 
Target VersionFixed in Version2.2.1 
Summary0005510: Installation fails with a fatal error if the database to be created already exists
Description1. Make sure ATutor is using mysqli and mysqli is enabled @ https://github.com/atutor/ATutor/blob/master/include/lib/vital_funcs.inc.php#L17-L19 [^]

2. Make sure the database to be created at the installation is already exists;

3. Install ATutor till the step where the database credentials are provided and click "Next" button at that step;

This error shows up:

Fatal error: Call to a member function real_escape_string() on a non-object in /Users/cindyli/Development/ATutor/include/lib/mysql_connect.inc.php on line 141
TagsNo tags attached.
Affects versionSVN
SVN Revision#na
Attached Files

- Relationships
related to 0005495closedgreg real_escape_string() fails on install (mysql 5.1.66) 

-  Notes
(0006929)
greg (administrator)
2014-08-21 19:49

What version of Mysql are you using?

see:
http://www.atutor.ca/atutor/mantis/view.php?id=5495 [^]
(0006930)
greg (administrator)
2014-08-21 19:52

Did try to resolve this issue, but found no suitable fix, other than commenting out this block:

https://github.com/atutor/ATutor/blob/master/include/install/install.inc.php#L461-L474 [^]
(0007300)
greg (administrator)
2016-01-06 10:22

seems to be okay now, installing when the db exists
(0007307)
greg (administrator)
2016-01-06 14:21

closed for 2.2.1

- Issue History
Date Modified Username Field Change
2014-08-21 10:02 cindy New Issue
2014-08-21 19:49 greg Note Added: 0006929
2014-08-21 19:52 greg Note Added: 0006930
2014-08-21 19:52 greg Relationship added related to 0005495
2016-01-06 10:22 greg SVN Revision# => na
2016-01-06 10:22 greg Note Added: 0007300
2016-01-06 10:22 greg Status new => resolved
2016-01-06 10:22 greg Fixed in Version => 2.2.1
2016-01-06 10:22 greg Resolution open => fixed
2016-01-06 10:22 greg Assigned To => greg
2016-01-06 14:21 greg Note Added: 0007307
2016-01-06 14:21 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker