MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005673ATutorSessionpublic2016-03-30 14:102018-05-16 19:13
Reportergreg 
Assigned Togreg 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionnot fixable 
PlatformOSOS Version
Product Version 
Target Version2.2.2Fixed in Version 
Summary0005673: Bounce not bouncing to public courses
DescriptionAfter changing a courses Access privileges to Public, there after, even if Access is changed back to protected or Private, it is not possible to get to the course through the My Start or Browse Courses course listing.

It is still possible to get to the public courses through Resume links with the My Start course listing (if there is one), or through the Jump menu.
Steps To ReproduceReproduced with PHP 5.6 and 7.1.1
Create a course
Make it public
Goes to My Start or Browse Courses
Click on the link to the course in the listing
You may need to repeat the above two steps
Page redirect to My Start with no message
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0005202new Module refresh Language Cache 
related to 0005842assignedcindy Session expires 10sec after viewing resource firefox 

-  Notes
(0007910)
greg (administrator)
2018-03-07 19:51

Works okay from jump menu
(0007913)
greg (administrator)
2018-03-09 19:52

Cindy, Here's another issue giving me some trouble. Hoping you figure out what's going on.
(0007914)
greg (administrator)
2018-03-09 19:54

Occurs across browsers, with cookies deleted, after browser and session restarted.
(0007915)
greg (administrator)
2018-03-10 09:31
edited on: 2018-03-10 09:43

Adding a SEP on the the end of the URL corrects the problem momentarily, but I have no idea why. after accessing the course, then returning to My Start, clicking the link again just reload My Start

(0007916)
greg (administrator)
2018-03-10 09:44
edited on: 2018-03-10 09:47

Emptying the cache works, but as soon as set to public, the link fails again

(0007917)
greg (administrator)
2018-03-10 10:19

The resume link only works once, then it just reload my start

Definitely cache related
(0007918)
greg (administrator)
2018-03-10 11:18

Temp hack for vitals.inc.php

    if (!defined('AT_INSTALL') || !AT_INSTALL) {
        header('Cache-Control: no-store, no-cache, must-revalidate');
        header('Pragma: no-cache');

        $relative_path = substr(AT_INCLUDE_PATH, 0, -strlen('include/'));
        header('Location: ' . $relative_path . 'install/not_installed.php');
        exit;
    } else{
        // Hack to disable caching until 5673 is resolved
        // Comment out two lines below to resume default caching
        header('Cache-Control: no-store, no-cache, must-revalidate');
        header('Pragma: no-cache');
    }
(0007983)
cindy (administrator)
2018-03-18 15:24

I haven't been able to reproduce the problem. What I've done:

1. On "Manage -> Properties" page, modified the access of a course back and forth in between "public" and "protected";
2. Use the "my start page" link on the breadcrumb to go back to the my start page;
3. Click the course on the my start page to get into the course.

The other way I tried to go to "my start page" is via the "jump" button at the top right corner.

The access has been changed more than 6 times, by using each way of going to the "my start page".

I'm always able to get into the course.

Do I miss something?
(0007984)
greg (administrator)
2018-03-18 17:22

I am able to reproduce the problem on the demo site.

Once you've switched the demo course to public, the first time you try to get back to the course from My Start, it works. Go back to My Start again, the second time it fails.
(0007985)
greg (administrator)
2018-03-19 18:16

Here's a link to the demo site:
https://www.atutorspaces.com/demo.php [^]
(0007986)
cindy (administrator)
2018-03-25 20:43

Interesting that I cannot reproduce the problem on the demo site too. Steps:

1. Go to Manage -> Properties, change "ATutorSpaces Demo" to public;
2. Use the "My Start Page" link on the breadcrumb navigation bar to go to "My Start Page";
3. Click the demo course to go into the course;
4. Repeat 5 times on step 2 and 3, everything works fine.

Then I tested more by logging out/logging back in, repeat steps above; also changing in between protected/public a couple of times, repeat steps above. None of them reproduced the problem.

I use firefox 59 for all tests.

I'm thinking you probably can try to purge all cached cookies from your browser and test again.
(0007987)
greg (administrator)
2018-03-26 09:02

Hmm? Just tested with FF on my work system, and there does not seem to be a problem. Strange how the problem occurs with all browser on my home machine.

I did try emptying the cache and deleting cookies. Initially that helped, but as soon as a course is switched to public, the problem repeats.

I guess this only happening on one machine, I'll mark it acknowledge and just monitor it for now.

Thanks for testing, and if anything comes to mind, let me know. thx
(0007988)
greg (administrator)
2018-03-26 09:02

Only seem to happen on when using Greg's laptop to access ATutor.
(0008000)
greg (administrator)
2018-05-15 19:29

only reproducible locally
(0008009)
greg (administrator)
2018-05-16 18:08

Reinvestigating. cache related, maybe something can be done by flushing the cache when bouncing or updating course properties.
(0008010)
greg (administrator)
2018-05-16 19:13

Not course properties related. problem still occurs after the cache is deleted, and a public course is accessed one. After the first access, bounce breaks.

Upon restart, same behaviour, one access to a public course then bounce breaks.

- Issue History
Date Modified Username Field Change
2016-03-30 14:10 greg New Issue
2016-04-17 10:55 greg Note Added: 0007394
2016-04-17 10:55 greg Assigned To => greg
2016-04-17 10:55 greg Status new => acknowledged
2018-03-07 19:09 greg Note Added: 0007904
2018-03-07 19:09 greg Status acknowledged => closed
2018-03-07 19:09 greg Resolution open => won't fix
2018-03-07 19:50 greg Status closed => new
2018-03-07 19:51 greg Note Added: 0007909
2018-03-07 19:51 greg Note Added: 0007910
2018-03-09 19:47 greg Status new => assigned
2018-03-09 19:47 greg Description Updated View Revisions
2018-03-09 19:47 greg Steps to Reproduce Updated View Revisions
2018-03-09 19:47 greg Note Deleted: 0007904
2018-03-09 19:47 greg Note Deleted: 0007909
2018-03-09 19:50 greg Assigned To greg => cindy
2018-03-09 19:50 greg Relationship added related to 0005842
2018-03-09 19:52 greg Note Added: 0007913
2018-03-09 19:53 greg Note Deleted: 0007394
2018-03-09 19:54 greg Note Added: 0007914
2018-03-10 09:31 greg Note Added: 0007915
2018-03-10 09:43 greg Note Edited: 0007915 View Revisions
2018-03-10 09:44 greg Note Added: 0007916
2018-03-10 09:47 greg Note Edited: 0007916 View Revisions
2018-03-10 10:19 greg Note Added: 0007917
2018-03-10 10:21 greg Description Updated View Revisions
2018-03-10 10:39 greg Resolution won't fix => open
2018-03-10 11:18 greg Note Added: 0007918
2018-03-12 17:35 greg Description Updated View Revisions
2018-03-13 17:26 greg Relationship added related to 0005202
2018-03-16 18:14 greg Steps to Reproduce Updated View Revisions
2018-03-18 15:24 cindy Note Added: 0007983
2018-03-18 17:22 greg Note Added: 0007984
2018-03-19 18:16 greg Note Added: 0007985
2018-03-25 20:43 cindy Note Added: 0007986
2018-03-26 09:02 greg Note Added: 0007987
2018-03-26 09:02 greg Note Added: 0007988
2018-03-26 09:02 greg Status assigned => acknowledged
2018-05-15 19:29 greg Note Added: 0008000
2018-05-15 19:29 greg Status acknowledged => closed
2018-05-15 19:29 greg Resolution open => not fixable
2018-05-16 18:08 greg Note Added: 0008009
2018-05-16 18:08 greg Assigned To cindy => greg
2018-05-16 18:08 greg Status closed => new
2018-05-16 19:13 greg Note Added: 0008010


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker