MantisBT

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005711ATutorSocialpublic2016-08-24 15:292016-08-24 16:19
Reportersudwebdesign 
Assigned Tosudwebdesign 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.2.3Fixed in Version2.2.3 
Summary0005711: Mysql query in profile
DescriptionThere is a left over mysql_query in the profile.php file, and $addslashes break the query.
TagsNo tags attached.
Affects versionSVN
SVN Revision#111a69d29e3ffadd71a634689a641fa81ef223f1
Attached Files

- Relationships

-  Notes
(0007498)
greg (administrator)
2016-08-24 15:32

mysql_query() to dbquery() in profile.
Serialize with slashes inside returning bad serialized string when ATutor read social settings.
Great Libre Web Learning in french comming soon (c'est du boulot a traduire)
(0007499)
greg (administrator)
2016-08-24 16:13

reassigning credit
(0007500)
greg (administrator)
2016-08-24 16:14

reassigned to sudwebdesign

- Related Changesets
ATutor: master 4a88ac40
Timestamp: 2016-08-24 10:17:32
Author: sudwebdesign
Details ] Diff ]
Fix mysql_query() warning in profile.php

Warning: mysql_query() expects parameter 2 to be resource, array given in ATutor/profile.php on line 35
Call Stack
# Time Memory Function Location
1 0.0002 237184 {main}( ) ../profile.php:0
2 0.0700 1192304 mysql_query ( )
../profile.php:35
mod - profile.php Diff ] File ]
ATutor: master c9f3703c
Timestamp: 2016-08-24 14:18:26
Author: sudwebdesign
Details ] Diff ]
Fix: social settings after saved preferences

when member save prefs and resave prefs, occur an error.
The unserialized prefs ares in wrong format because of \" inside.
Probably wooops

Fatal error: Call to a member function setProfile() on a non-object in
ATutor/mods/_standard/social/settings.php on line 67
mod - mods/_standard/social/lib/classes/PrivacyControl/PrivacyController.class.php Diff ] File ]
ATutor: master 111a69d2
Timestamp: 2016-08-24 15:30:23
Author: greg
Committer: GitHub
Details ] Diff ]
Merge pull request 0000118 from sudwebdesign/master

5711: Fixes mysql_query to dbquery && fatal error on save social prefs. Thanks for that sudwebdesign! If you register on our issue tracker, I can assign the fix to you.
http://www.atutor.ca/atutor/mantis/ [^]
mod - mods/_standard/social/lib/classes/PrivacyControl/PrivacyController.class.php Diff ] File ]
mod - profile.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-24 15:29 greg New Issue
2016-08-24 15:32 greg SVN Revision# => 111a69d29e3ffadd71a634689a641fa81ef223f1
2016-08-24 15:32 greg Note Added: 0007498
2016-08-24 15:32 greg Status new => resolved
2016-08-24 15:32 greg Fixed in Version => 2.2.3
2016-08-24 15:32 greg Resolution open => fixed
2016-08-24 15:32 greg Assigned To => greg
2016-08-24 15:35 greg Assigned To greg =>
2016-08-24 16:12 greg Reporter greg => sudwebdesign
2016-08-24 16:12 greg Assigned To => sudwebdesign
2016-08-24 16:13 greg Note Added: 0007499
2016-08-24 16:13 greg Status resolved => feedback
2016-08-24 16:13 greg Resolution fixed => reopened
2016-08-24 16:14 greg Note Added: 0007500
2016-08-24 16:14 greg Status feedback => resolved
2016-08-24 16:14 greg Resolution reopened => fixed
2016-08-24 16:16 greg Changeset attached => ATutor master 4a88ac40
2016-08-24 16:16 greg Changeset attached => ATutor master c9f3703c
2016-08-24 16:19 greg Changeset attached => ATutor master 111a69d2


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker