Community Forums

ATutor Modules

Payments 1.7 Module


You must be signed-in to post.

AuthorSubject
 
Page: 1
es24tv

Avatar for es24tv
Subject: Payments 1.7 ModuleQuote this post in your reply
Failure to install: warning
"The following errors occurred:
ATutor was unable to access the database. If the problem persists, Please report this to an Administrator With This date reference (...)"

Things to describe:
Operating system ATutor is installed on -
ATutor version 2.2
Patch #s applied 1 ("partly"), 2 ("partly") and 3
ATutor theme name Bluemin
PHP version 5.3.3
MySQL version 5.1.73
Web browser being used Firefox, Chrome
...and anything else relevant UPGRADE FROM 2.1
Posted: 2014-09-19 12:37:56
greg

Avatar for greg
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
I've reported the issue. Will try to get to it as soon as possible.

atutor.ca/atutor/mantis/view.php?id=5535

Are you able to install other modules for ATutor 2.2?
Posted: 2014-09-19 14:31:09
es24tv

Avatar for es24tv
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
Yes; before "Payments" I installed "Assignment Dropbox" without any problem.

And then "Vimeo" (to test) and all OK. The problem persists with Payments.

Thank you, Greg.
Posted: 2014-09-19 14:45:04
greg

Avatar for greg
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
Hmm? Assignment dropbox and Vimeo are not available for ATutor 2.2. They are already part of ATutor.
Posted: 2014-09-19 14:51:04
es24tv

Avatar for es24tv
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
1) I have not seen that it was "Vimeo" in the list of installed modules. Po that chose that for proibar.

2) "Assignment Dorpbox" if you've seen built, but was awaiting installation as I did (and I uninstalled the "extra").

3) Problem, I would choose another module to try and tell you what happens, but I find this problem in the module catalog <code> ... mods / _core / modules / install_modules.php </ code>

a) I select "Certify" and want to install "Mehara"

b) I select "Google Calendar" and you want to install "ATutor Multisite Manager"

I would like to test it but I fear harming installed so far ...
Posted: 2014-09-19 15:12:52
greg

Avatar for greg
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
I still not quite sure I understand.

Keep in mind that modules for earlier versions of ATutor will not be compatible with ATutor 2.2 if they use the database. The database layer has change in 2.2.

Certify and Google Calendar are not available yet for 2.2. There is a new Calendar module included standard with ATutor that already supports google calendar. You would just need to enable it in the Admin's module manager.


There was little use of the Mahara module, so it is no longer being supported. It and some of the other modules for older versions of ATutor are left available so anyone who wants to update them to work with new versions of ATutor can do that.

If you are experimenting and worried breaking something, I'd suggest setting up a separate version of ATutor for that.

You can also try experimenting with the ATutor demo, to see if you can reproduce the problems there.

www.atutor.ca/atutor/demo.php
Posted: 2014-09-19 15:31:56
es24tv

Avatar for es24tv
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
Thank You, Greg.

I see that the payments module is installed on the 2.2 demo site. It is true?

When I try to install it on my site gives the error message: "ATutor was unable to access the database..."

I consult: will an update to use the payments module in version 2.2, no there is an error in my update from 2.1 to 2.2?

Regards,

Mario
Posted: 2014-09-20 04:50:14
greg

Avatar for greg
Subject: Re: Payments 1.7 ModuleQuote this post in your reply
The problem seems to be the result of installing the module over an existing version of the module. So, I've created a new version (1.8) that will allow you to install over the existing module.

Unfortunately the change will break the uninstall, but we'll deal with that in a future version of ATutor. For now the module will need to be inistalled manually.

You can now download version 1.8 of the module, or install from module listed under the Install Modules tab in the Module Manager.

If you have translated the module, you should create a backup of the translation. Installing v1.8 will replace the existing language for the module with the default language (English).
Posted: 2014-09-20 10:00:41
 
Page: 1

You must be signed-in to post.

Related Articles