Community Forums

AChecker

Encoded response from the aChecker rest service

AuthorSubject
 
Page: 1
TheDude
Subject: Encoded response from the aChecker rest serviceQuote this post in your reply
I'm playing around with the aChecker rest api. I'm having some problems parsing the http response. If I do the following request:

achecker.ca/checkacc.php?uri=http://www.google.com&id=mykey&output=rest

i'm getting the following response:

...
<result>
<resultType>Potential Problem</resultType>
<lineNum>1</lineNum>
<columnNum>99</columnNum>
<errorMsg>...</errorMsg>
<errorSourceCode>...</errorSourceCode>
<sequenceID>3</sequenceID>
<decisionPass>...</decisionPass>
<decisionFail>...</decisionFail>
</result>

Why are the seQuenceID, Pass and Fail elements html encoded?

Regards,
Thomas
Posted: 2010-05-08 12:38:22
TheDude
Subject: Re: Encoded response from the aChecker rest serviceQuote this post in your reply
Sorry. Response is following:

...
<result>
<resultType>Potential Problem</resultType>
<lineNum>1</lineNum>
<columnNum>99</columnNum>
<errorMsg>...</errorMsg>
<errorSourceCode>...</errorSourceCode>
& lt;sequenceID& gt;3& lt;/sequenceID& gt;
& lt;decisionPass& gt;...& lt;/decisionPass& gt;
& lt;decisionFail& gt;...& lt;/decisionFail& gt;
</result>
Posted: 2010-05-08 12:40:36
TheDude
Subject: Re: Encoded response from the aChecker rest serviceQuote this post in your reply
Does anyone replies at this forum?
Posted: 2010-05-18 10:21:35
cindy

Avatar for cindy
Subject: Re: Encoded response from the aChecker rest serviceQuote this post in your reply
You will hit parse error if the response content is not encoded.

@See xml.silmaril.ie/authors/specials/
Posted: 2010-05-18 10:40:28
TheDude
Subject: Re: Encoded response from the aChecker rest serviceQuote this post in your reply
I don't understand. Why do I get & lt;sequenceID& gt;... in the response data rather than <sequenceID>...?
Posted: 2010-05-18 12:03:24
cindy

Avatar for cindy
Subject: Re: Encoded response from the aChecker rest serviceQuote this post in your reply
I see. The XML tags themselves are encoded. Sorry about the misunderstanding. Thanks for the report.

This bug has been confirmed and just fixed at achecker.ca
Posted: 2010-05-18 13:47:28
 
Page: 1

You must be signed-in to post.

Related Articles