Community Forums

ATutor Bug Reports

Create User List


You must be signed-in to post.

AuthorSubject
 
Page: 1
ipool

Avatar for ipool
Subject: Create User ListQuote this post in your reply
Things to describe:
operating system - Unix
version of ATutor - 1.5.3.3

When I Create new Users under Enrollment, Create Course List, I've found the following error:

The Usernames
123e01
123e02
123e03
Are changed to 123 and only the first one will be createt.
So the information after the "e" has been deletet.
Posted: 2007-03-23 03:00:52
greg

Avatar for greg
Subject: Re: Create User ListQuote this post in your reply
Can you provide more detail. I am unable to reproduce the problem.

What were the name you used to generate these username?
Posted: 2007-03-23 09:01:13
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
I insert as example under
/tools/enrollment/create_course_list.php

The following names and adresses:
Thom, Taenn, azert@ipool.ch
Thome, Taennle, qzert@ipool.ch
Thomi, Tanner, gtert@ipool.ch
(Fake adresses)

Klick on Add to Course List

Change Loginnames to:
123e01
123e02
123e03
then I use Add to Enrolled List button

The Message apears:
The following Students are addet sucsessfully: 123
(Ore similar, because it apears in German)

After I Check the Enrolled Members, there is only the First one in the List as User 123.
Posted: 2007-03-23 11:21:18
joel

Avatar for joel
Subject: Re: Create User ListQuote this post in your reply
We still can't reproduce this.

I think it would be best if you tried the 1.5.4 Beta and see if you can reproduce that there.
Posted: 2007-03-23 13:29:22
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
That will take a while, because actualy I have no FTP accses. I try to make it next week.
Posted: 2007-03-26 01:52:11
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
Ok, I tryed it on your Demo ATutor 1.5.4 amd the same dit happend again.
www.atutor.ca/atutor/demo154/tools/enrollment/verify_list.php

I aded the users 123e01, 123e02 and 123e03
Only the first one apears as user 123
Posted: 2007-04-04 01:34:53
joel

Avatar for joel
Subject: Re: Create User ListQuote this post in your reply
See if you can reproduce this on the demo server and which browser you're using.

Provide us with the exact steps you used starting from when you login.
Posted: 2007-04-05 10:11:07
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
Ok. I can make it on your Demo
Step by step:
- First i Loged in as instructor
- go to "Manage"
- Go to "Create Course List"
- Fill out more then one user in this form (I made three fake ones)
- Klick "Add to Course List"
- Change the loginnames to 111e11, 111e12 and 111e13 (Two numbers sepperatet by an "e" )
- Klick "Add to Enroled List"
- The following Message apears: "The following unique accounts were successfully added to the course list:
111"

So only the first one is enrolled as User 111.
I think there is somewhere a problem with the "e" in the middle of the numbers, because it looks like everything after the the "e" is ignored and even the "e" is removed from the Sintax.

I used Internet Explorer V6 vor this. I did not try it on a other one till jet.
Posted: 2007-04-23 10:55:16
vegard

Avatar for vegard
Subject: Re: Create User ListQuote this post in your reply
I can also reproduce this at your server, tried with 111e11, 111e12, 111e13 and I just got an empty course list.

also, tried with different numbers and letters, which worked:

"
The following unique accounts were successfully added to the course list:

* 222f11
* 222f12
* 222f13
"
Posted: 2007-04-24 06:45:17
vegard

Avatar for vegard
Subject: Re: Create User ListQuote this post in your reply
used Firefox 2, BTW
Posted: 2007-04-24 06:45:36
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
I tryed also with other letters in between as the "e" but it dit not create the error.
Posted: 2007-04-24 07:01:47
joel

Avatar for joel
Subject: Re: Create User ListQuote this post in your reply
Try replacing your include/lib/enroll.inc.php file with this one:
atutorsvn.atrc.utoronto.ca/repos/atutor/trunk/docs/include/lib/enroll.inc.php
Posted: 2007-04-24 10:10:55
ipool

Avatar for ipool
Subject: Re: Create User ListQuote this post in your reply
I tryed on my ATutor 1.5.3.3 server.
The error is still the there.
Sorry

For your information
The Users can be createt correctly in the admin aerea.
Posted: 2007-04-24 10:35:22
 
Page: 1

You must be signed-in to post.

Related Articles