Community Forums

ATutor Bug Reports

bugs when installing Atutor 1.5.4


You must be signed-in to post.

AuthorSubject
 
Page: 1
vegard

Avatar for vegard
Subject: bugs when installing Atutor 1.5.4Quote this post in your reply
hi,

have tried to install 1.5.4 on two different systems, and get the following errors at both:


Warning: opendir(/home/apache/www2.helseutdanning.no/atutor154/content//feeds) [function.opendir]: failed to open dir: No such file or directory in /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php on line 42

Warning: readdir(): supplied argument is not a valid Directory resource in /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php:42) in /home/apache/www2.helseutdanning.no/atutor154/login.php on line 168

Warning: Cannot modify header information - headers already sent by (output started at /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php:42) in /home/apache/www2.helseutdanning.no/atutor154/include/header.inc.php on line 17

Warning: Cannot modify header information - headers already sent by (output started at /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php:42) in /home/apache/www2.helseutdanning.no/atutor154/include/classes/Language/Language.class.php on line 123


this appears at the top of the page when installation is done, and you are at the login screen. when trying to log in I get this:


Warning: opendir(/home/apache/www2.helseutdanning.no/atutor154/content//feeds) [function.opendir]: failed to open dir: No such file or directory in /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php on line 42

Warning: readdir(): supplied argument is not a valid Directory resource in /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at /home/apache/www2.helseutdanning.no/atutor154/mods/_standard/rss_feeds/module.php:42) in /home/apache/www2.helseutdanning.no/atutor154/login.php on line 109


..and nothing more.

this system is Linux hu2 2.6.18-1-686, Apache/2.2.3 (Debian), PHP Version 4.4.4-9, MySQL 5.0.36

the other system is my localhost:
Web Server: Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 PHP Version: 5.1.6 MySQL Version: 5.0.24a-community-nt

the first error is the same at both systems, but the second (after login) is a tad different on my localhost:


Warning: opendir(C:\Program Files\xampp\htdocs\ATutor\content\/feeds) [function.opendir]: failed to open dir: Invalid argument in C:\Program Files\xampp\htdocs\ATutor\mods\_standard\rss_feeds\module.php on line 42

Warning: readdir(): supplied argument is not a valid Directory resource in C:\Program Files\xampp\htdocs\ATutor\mods\_standard\rss_feeds\module.php on line 44

Warning: session_regenerate_id() [function.session-regenerate-id]: Cannot send session cookie - headers already sent by (output started at C:\Program Files\xampp\htdocs\ATutor\mods\_standard\rss_feeds\module.php:42) in C:\Program Files\xampp\htdocs\ATutor\login.php on line 63

Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\xampp\htdocs\ATutor\mods\_standard\rss_feeds\module.php:42) in C:\Program Files\xampp\htdocs\ATutor\login.php on line 109


..on both I cannot continue after this step.
Posted: 2007-04-17 04:56:30
greg

Avatar for greg
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
Thats a shame! Somthing must have broke at the last minute. There will be a new download avialable shortly.
Posted: 2007-04-17 08:37:01
greg

Avatar for greg
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
For some reason the content subdirectories are not created, we'll fix that shortly. For now you can just create a directory called "feeds" and make it writable. That should get you up and running.
Posted: 2007-04-17 08:44:48
vegard

Avatar for vegard
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
thanks Greg!

no sweat, I'll just wait till you have a new download available and try again then.
Posted: 2007-04-17 08:47:06
madran

Avatar for madran
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
I have a same problem. I create a "feed" directory but there action did not fix it

Warning: opendir(/var/www/web2/web/content//feeds) [function.opendir]: failed to open dir: No such file or directory in /var/www/web2/web/mods/_standard/rss_feeds/module.php on line 42

Warning: readdir(): supplied argument is not a valid Directory resource in /var/www/web2/web/mods/_standard/rss_feeds/module.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web2/web/mods/_standard/rss_feeds/module.php:42) in /var/www/web2/web/login.php on line 168

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web2/web/mods/_standard/rss_feeds/module.php:42) in /var/www/web2/web/include/header.inc.php on line 17

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web2/web/mods/_standard/rss_feeds/module.php:42) in /var/www/web2/web/include/classes/Language/Language.class.php on line 123


Things to describe:
operating system -
version of ATutor -
versions of php -
version of mysq l -
webserver & version -
copies of error messages -
changes to default settings -
web browser being used -
and anything else relevant -
Posted: 2007-04-17 09:10:12
madran

Avatar for madran
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
Sorry, I forgot to write system properties.

Things to describe:
operating system - Linux
version of ATutor - 1.5.4
versions of php - 5
version of mysq l - 5
webserver & version - Apache 2.0
copies of error messages - I Write it previous messege
changes to default settings - No
web browser being used - Internet Explorer
and anything else relevant -
Posted: 2007-04-17 09:16:39
greg

Avatar for greg
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
Sorry. That should have been "feeds".


Hold off for a few hours. There's some other problems with the installer. We are going to put together another bundle, then download and install it. I'll post a message here when the new bundle is ready.
Posted: 2007-04-17 09:36:42
vegard

Avatar for vegard
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
don't know if this is relevant, but posting it for your reference:

I did notice something when installing on my localhost that hasn't been the case when doing this earlier. at the "content directory" step Atutor identifies this directory:

C:\Program Files\xampp\htdocs\ATutor\content

and not, say:

/var/htdocs/Atutor/content or localhost/Atutor/content

...which it has done previously
Posted: 2007-04-17 10:05:53
greg

Avatar for greg
Subject: Re: bugs when installing Atutor 1.5.4Quote this post in your reply
The updated download should be available now. It has been up for about an hour now, and downloads from the primary sourceforge mirror, but may take a few hours to make its way to all the mirrors, depending where you are in the world.
Posted: 2007-04-17 11:17:32
 
Page: 1

You must be signed-in to post.

Related Articles