Community Forums

ATutor Bug Reports

Bugs found in ATutor 1.5.5


You must be signed-in to post.

AuthorSubject
 
Page: 1
IndieRect

Avatar for IndieRect
Subject: Bugs found in ATutor 1.5.5Quote this post in your reply
Most of these bugs have been checked for reproducibility in ATutor 1.5.5 demo installation.

/admin/language.php: Clicking buttons when no item is selected returns various error messages; all of them are misleading.

/inbox/sent_messages.php: Clicking a table row does nothing.
/inbox/sent_messages.php: Clicking "Delete" when no item is selected returns the same page unchanged (nothing is deleted and no errors issued).
/inbox/sent_messages.php: Clicking "Move to Inbox" when no item is selected shows "Action completed successfully." feedback instead of an error, and nothing gets changed.

/tools/chat/index.php: Clicking a table row does nothing.
/tools/chat/index.php: Clicking "View" with neither item selected returns a page with broken layout (when Atutor or Atutor Classic themes are being used).
/tools/chat/index.php: Clicking "Delete" with neither item selected returns an error AT_ERROR_NOT_FOUND that is not in DB.

/tools/links/*.php: Clicking on "Add Link" brings /tools/links/index.php page.

/forum/view.php: Subscription tool is duplicated on this page.

/include/vitals.inc.php: No space between number and measurement unit (m, h, s).

/faq/index_instructor.php, maybe elsewhere: Switching between languages causes an AT_ERROR_NO_ITEM_SELECTED to occur. This is because of logical errors when checking $_GET.

Admin's inability to switch language (http://atutor.ca/view/3/8595/1.html#8610) still persists. It occurs only when there are 5 or less languages installed. ATutor appears to handle language saving by means of two independent procedures: directly in vitals.inc.php and via Language class.

Translator interface: Terms A, B, ..., J after being translated are always shown as updated (when viewed file-by-file).

The pages on which language vars are present are not written into the AT_language_pages if they are present on an included page (e.g. question types in /tools/tests/question_db.php).

Just a suggestion: Using MiB instead of MB, the usage required by IEEE 1541, IEC 60027-2 and gaining some acceptance in open-source.
Posted: 2007-08-15 06:08:56
harris

Avatar for harris
Subject: Re: Bugs found in ATutor 1.5.5Quote this post in your reply
Does this bug exist in 16? I can't reproduce it.


...Admin's inability to switch language (http://atutor.ca/view/3/8595/1.html#8610) still persists. It occurs only when there are 5 or less languages installed. ATutor appears to handle language saving by means of two independent procedures: directly in vitals.inc.php and via Language class...
Posted: 2008-01-09 13:58:16
IndieRect

Avatar for IndieRect
Subject: Re: Bugs found in ATutor 1.5.5Quote this post in your reply
If you don't mind, I've responded to www.atutor.ca/atutor/mantis/view.php?id=3245 directly.
Posted: 2008-01-10 07:23:03
 
Page: 1

You must be signed-in to post.

Related Articles