Community Forums

ATutor Bug Reports

1.6.1 beta 2: various


You must be signed-in to post.

AuthorSubject
 
Page: 1 | 2 | 3
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
I'm sure adjusting sizes for each media separately will unavoidably complicate things. Put your work in a separate file, and require it into output.inc.php, and comment out the current line in the file.
Posted: 2008-06-16 08:32:19
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
I think you can safely remove the second instance of YouTube.
Posted: 2008-06-16 08:34:58
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
The "current line in the file" is the entire embed_media function, which I am rewriting to make this work. I could comment it all out and put the new function in a new file if you want me to, otherwise I'll just replace the existing function. (I can keep the old one in comments for easy comparison).

A new issue: in the process of testing the rewritten embed_media function I had to resize the max file size for a course, and just put a 0 at the end of the old max file size in the admin panel (multiplying it by 10). Having done this, the content editor file manager told me that there was no content folder anymore, and asked if I wanted to make one. I logged out and tried to log back in, but now my password doesnt work anymore. I checked the db and tried sha1-hashing my password in a sha1 maker, and it matches, but somehow the login process won't accept my password.

Suggestions?
Posted: 2008-06-16 08:42:04
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
I can't say for sure what's happened with course size adjustment.

One thing that did change recently is the addition of password encryption for all users, which might cause your login problem. If you are using the redux theme, it might also need adjustment to accommodate password encryption.

I'd suggest starting over with a fresh copy of ATutor from Subversion. When you do run update, watch for the database files in the update output. If they show up, scan through them and manually apply any new changes to your development version's database. (i.e.install/db/atutor_upgrade_1.6_to_1.6.1.sql)
Posted: 2008-06-16 09:20:04
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
The problem was with the redux theme yes, although I did get that funny message when adjusting course size. (Don't remember the exact error msg, sorry..)

I'm using subversion now and updating daily.


New issue: when I set default language for a course it doesn't really seem to affect anything. The reason I mention this is that we're planning on removing the users' option to translate between languages, and instead letting the language be enforced by the instructor for a given course. However, when I have default server language set to norwegian and default language for a course set to english, the user is met with norwegian both in the login page and in the course page(s). Not sure if this is a bug or if I've just overlooked something..?
Posted: 2008-06-17 05:19:20
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
The language set in the student's preferences will override the course or system defaults language.

Forced language is being proposed as a feature for a future release.
Posted: 2008-06-17 08:16:20
vegard

Avatar for vegard
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
..the problem is that there are no language options in the students preferences anymore, they were removed when we added default course language several versions ago..

we'd like to fix this now if we can, so what would be the best way to go forward with it? I propose that a course can force a language, and that will always override whatever the student chose before (via the "translate" feature) - any objections?
Posted: 2008-06-17 08:22:21
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
The language preference is now set using the language selector an the bottom of the screen.

As long as the default remains the student's choice, I have no objection to adding a course language override preference. I can see this being useful in language based courses where you might not want the learner to view the site in their native language, or visa versa.

It is getting a little late for adding new features if your intent was to get it into 1.6.1. If we add it, it should go in before the first RC release, which I was going to do today. I could hold off for a day or two if you wanted to try to put a patch together. Let me know.
Posted: 2008-06-17 08:38:13
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
So what you mean is that the default language option should be reintroduced to student preferences, because having course override would render the translate button at the bottom useless.

This would mean that the user decides which language ATutor has when he's not inside a course with a forced language.

Don't hold off on RC1 for this, we're not ready to send any code right now anyway.
Posted: 2008-06-17 08:46:32
greg

Avatar for greg
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
Language is still a student preference, it just happens to be set using the language selector in the footer.
Posted: 2008-06-18 10:45:14
vegard

Avatar for vegard
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
true, I suggest we leave the "translate to" feature as it is for all pages outside of a course.

then I suggest we have an "available languages" feature (checkboxes) on the course properties page, which might default to all. if all are available there is no difference from today.

however, if we choose only *one* language under available languages, this language is forced on that course, and the "translate to" links are not displayed.

does that sound ok?
Posted: 2008-06-18 14:45:23
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
Please let us know how you would want the force language options implemented, and we'll have a look at it.


Found a new bug, both in the latest 1.6.1 from svn and in 1.6: If your preferred editor mode is set to Plaintext and you make a new course announcement in HTML, choosing the HTML radio button but not using the visual editor, the entry is stored as plaintext and not as html. It works correctly for adding content pages, but not for announcements, and it works correctly if HTML is your default editor mode set in Preferences.
Posted: 2008-06-19 04:01:45
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
Another thing, the patcher seems slightly bugged in the 1.6.1 beta: When installing patches they don't show up in the list of patches anywhere..
Posted: 2008-06-19 04:04:34
cindy

Avatar for cindy
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
Do you mean the list of available patches are not displayed on patcher main page?

It's because patches rely on ATutor version. There's no patch created for 1.6.1 so far as it's in beta.

Thanks.
Posted: 2008-06-19 09:38:46
gorzan

Avatar for gorzan
Subject: Re: 1.6.1 beta 2: variousQuote this post in your reply
well, that's one thing, but don't the patches I install manually show up anywhere? the ones i install from zip files that i made when i ran 1.6..?
Posted: 2008-06-19 09:53:37
 
Page: 1 | 2 | 3

You must be signed-in to post.

Related Articles