Community Forums

ATutor Bug Reports

User Time Zone settings


You must be signed-in to post.

AuthorSubject
 
Page: 1
crusty
Subject: User Time Zone settingsQuote this post in your reply
If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on - linux
ATutor version - 1.6.2
Patch #s applied - all
ATutor theme name - ATutor 1.5
PHP version - 5.2.9
MySQL version - 5.0.5 community
Webserver & version - apache 2
Web browser being used - Opera 9.64

The changelog for version 1.6.2 says:

"New System Preferences: Administrators can now set the local time zone for ATutor, and user can set their own local time zone if it differs."

I have the System Preferences - Time Zone Offset = -6 which is correct for the server location.

I have the Default Preferences - Time Zone Offset = -4 which is correct for users.

All users have the My Start Page - Preferences - Time Zone Offset = -4.

I expect the time shown in the upper right corner of web pages to show the local time, but it always shows the server time.

Do I misunderstand the purpose of the User Preference Time Zone Offset?

It might be helpful if the datetime that is displayed beside the System Preferences - Time Zone Offset was identified as being the server datetime since it does not change when the offset value is changed.
Posted: 2009-04-27 10:57:36
harris

Avatar for harris
Subject: Re: User Time Zone settingsQuote this post in your reply
Bug confirmed. Thanks.
Posted: 2009-04-27 11:37:19
harris

Avatar for harris
Subject: Re: User Time Zone settingsQuote this post in your reply
Please apply patch #0021 to fix this problem.
Posted: 2009-04-27 11:55:35
wilsoncortez
Subject: Re: User Time Zone settingsQuote this post in your reply
Thank you Harris
Patch applied :-)
Posted: 2009-04-28 11:07:30
 
Page: 1

You must be signed-in to post.

Related Articles