Community Forums

ATutor Bug Reports

Upgrade 2.1.1 script gives fatal error when running 'Step 2: Database'.


You must be signed-in to post.

AuthorSubject
 
Page: 1
komputist
Subject: Upgrade 2.1.1 script gives fatal error when running 'Step 2: Database'.Quote this post in your reply
We have ATutor 2.1. We try to upgrade to ATutor 2.1.1. We have PHP version 5.4.11.

PROPBLEM: When I click on the 'Next' button in order to perform 'Step 2: Database', I get the following message:

Fatal error: Cannot re-assign auto-global variable _POST in /home/russisk/public_html/atutoromsetjar/install/include/ustep7.php on line 526
Posted: 2013-03-20 18:07:52
greg

Avatar for greg
Subject: Re: Upgrade 2.1.1 script gives fatal error when running 'Step 2: Database'.Quote this post in your reply
Yes, there would appear to be a problem.
atutor.ca/atutor/mantis/view.php?id=5237

Should have a new bundle with the fix to download within the next day.
Posted: 2013-03-20 19:01:07
greg

Avatar for greg
Subject: Re: Upgrade 2.1.1 script gives fatal error when running 'Step 2: Database'.Quote this post in your reply
A new bundle has been posted, and should be ready for download now.

https://sourceforge.net/projects/atutor/
Posted: 2013-03-21 10:58:30
komputist
Subject: Re: Upgrade 2.1.1 script gives fatal error when running 'Step 2: Database'.Quote this post in your reply
Thanks for the quick update. Here is my report, thus far:

1. I keep another install where I experiment. However, for various reasons, the experiment install runs Atutor version 2.0.3 - and not Atutor 2.1. Perhaps this detail is important?

2. When I run the new update script, then, when 'Step 2 Database' has ben run, I ge the following message (see below):


Strict Standards: Declaration of BlogPostsCommentsTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 756

Strict Standards: Declaration of FaqEntriesTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 979

Strict Standards: Declaration of ForumsTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1042

Strict Standards: Declaration of ForumsThreadsTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1124

Strict Standards: Declaration of FoldersTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1163

Strict Standards: Declaration of FilesTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1210

Strict Standards: Declaration of FilesCommentsTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1244

Strict Standards: Declaration of GroupsTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1352

Strict Standards: Declaration of LinksCategoriesTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1491

Strict Standards: Declaration of LinksTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1525

Strict Standards: Declaration of TestsAnswersTable::getContent() should be compatible with ATutorTable::getContent($courseDependent = true) in atutor211/install/include/classes/TableConversion.class.php on line 1866
Posted: 2013-03-23 14:03:31
 
Page: 1

You must be signed-in to post.

Related Articles