Community Forums

ATutor Bug Reports

Preview tool does not work


You must be signed-in to post.

AuthorSubject
 
Page: 1
user29
Subject: Preview tool does not workQuote this post in your reply
I installed ATutor 2.2.2 and when I go to edit a web page and then I try to preview the content I get a new window with the raw HTML code instead of the rendered content. I tested it in both a server and a local installation.

Could you please confirm me if you get the same behaviour in your installation?

I tried to use the ATutor demo but the instructor demo is not loading:
https://demo.atutorspaces.com/1/index.php

Thanks in advance!
Posted: 2016-07-21 04:58:18
greg

Avatar for greg
Subject: Re: Preview tool does not workQuote this post in your reply
I'm not able to reproduce the problem. Can you provide any more details?
Posted: 2016-07-21 07:11:15
user29
Subject: Re: Preview tool does not workQuote this post in your reply
When I go to edit a page in the ATutor demo, for instance the following one:
https://demo.atutorspaces.com/mods/_core/editor/edit_content.php?cid=17

And then I click on the "Preview" tool I see the content of the page with HTML tags.

To solve this in my local installation I modified the file "[ATUTOR]/mods/_core/editor/preview.php" Line 66 by adding html_entity_decode:

echo html_entity_decode(format_content($stripslashes($_POST['body_text']), $_POST['formatting'], $_POST['glossary_defs']));

It works but I do not know if it is the right solution.

Thank you!
Posted: 2016-07-25 09:26:51
 
Page: 1

You must be signed-in to post.

Related Articles