Community Forums

Translation

Vietnamese language pac ATutor 2.2.2 For Review


You must be signed-in to post.

AuthorSubject
 
Page: 1
danghoaiphuc
atutor_2_2_2_vi.zip
Subject: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Hi Greg and All,
I started to translate from the pack download on ATutor website for Vietnamese. I imported into my ATutor site and started translating. I did quite lots of translations and it worked well. However, after I exported the Vietnamese 2.2.2 pack and tested with other Vietnamese pack to see if it has the same encoding issue as my original downloaed one has or not. Then I see it's the same.
Then, I imported my 2.2.2 Vietnamese pac again and it doesn't accept to import anymore.
Can you help to checck with this attached language pack? Thanks and await for your support.
Posted: 2017-04-01 05:24:41
greg

Avatar for greg
atutor_2_2_2_vi1.zip
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Check your database to be sure it using utf-8 character encoding. You should be able to see this in the table properties for the language_text table, in particular.

And also check to be sure the the database connection is using utf-8.

I've attached the exported VI pack from my local ATutor installation. See if you can import it.
Posted: 2017-04-01 06:01:22
danghoaiphuc
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Hi Greg,
Can you upload the file again? can read your filename but cannot activate to download it. Fyi, my database collation is utf-8 and I also see the language_text table is utf-8 as In addition, if no problem from your side, can you add it to the translation server of ATutor so I might start translating from there and export the pack from aTutor server as well. Thanks for help.
Posted: 2017-04-01 07:42:56
greg

Avatar for greg
atutor_2_2_2_vi1.zip

Attachment: atutor_2_2_2_vi1.zip
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Here is the VI pack again.

I was not able to use the language pack you had exported.

I'm not sure why your export is breaking if your database is set to UTF-8.
Posted: 2017-04-01 09:46:13
greg

Avatar for greg
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
You should be able to translate from atutor.ca, based on the language in the language pack attached above.
Posted: 2017-04-01 09:49:12
danghoaiphuc
atutor_2_2_2_vi_withGeneralHelpVariable.zip
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Thanks Greg for help. Finally, I find some clue for the issue. It's the problem of sql syntax error. As everytime I manually import from the phpMyAdmin into the language_text table, it occurs the syntax error.
Can you please check with this varial: "general_help"? Here are the English text and below is the Vietnamese text copied from the language_text.sql Vietnamese file:
For guidance on using ATutor see the official <a href="%1$s" onclick="poptastic('%1$s'); return false;" target="new"><strong>ATutor Handbook</strong></a>.
('vi', '_template', 'general_help', 'Cho phần hướng dẫn sử dụng, hãy xem <a href=\"%1$s\" onclick=\"poptastic(\\'%1$s\\'); return false;\" target=\"new\"><strong>Sổ tay ATutor</strong></a>.', '2017-04-02 03:54:25', ''),

I don't know what is the error but that's one of the errors that I got for my previous translation. And it doesn'is impossible to import into the database. Here I attached the new file with that string. If you remove the string above, it would go through. Is it a bug of ATutor? As I am not sure to go on with the translation or not. Please advice. Thanks Greg.
Posted: 2017-04-01 17:19:48
greg

Avatar for greg
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
If you have not already, read the translator documentation
www.atutor.ca/atutor/docs/translate.php

Can you confirm you are using the ATutor translator to add new language, and importing and exporting using the ATutor language manager. You should not need to import the language using phpMyAdmin.

The problem you are experiencing I cannot reproduce. I suspect you are doing something wrong.
Posted: 2017-04-01 19:25:00
danghoaiphuc
Subject: Re: Vietnamese language pac ATutor 2.2.2 For ReviewQuote this post in your reply
Thanks Greg for quick response. Here the are Below are step by step I followed. I used the ATutor translation. My team at Sao Mai center for the blind has contributed most for the Vietnamese translation of ATutor, around 1.5.3. So I am quite familiar with the system. After switching to Vietnamese and activating the Translate button. It opens a translation window with the sentence like this:
"From English - iso-8859-1 to Vietnamese - utf-8"
1. Choose "Templates" and start translate the *update* and *new* strings.
2. Please try under the "/about.php" template with the variable "general_help", something like for guidance, please see the ATutor handbook...
3. We translate, or even you can try to copy the same line of the original English text and pstate into text edit field, then save.
4. Choose Vietnamese under the "Language" and export. After that, delete the Vietnamese language from the system.
5. Re-import the exported file from step 4 to see how it works. It will occurs the following error:
"The following errors occurred:
ATutor was unable to access the database. If the problem persists, please report this to an Administrator with this date reference (04/02/2017 01:08:58 am)"

If I try to manually import from the phpMyAdmin, under the language_text table, it will show #1064 syntax error, as followed:
"#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\\'); return
false;\" target=\"new\"><strong>Sổ tay ATutor</strong></a>.', '20' at line 847"

6. Removing that line will solve the problem.

So what I m wondering here is the bug when ATutor converts the translation strings into the database, or the MySQL is not compatible with the syntax. I am not good at sql structure. So can you kindly help reproduce from steps to advice what issues are happening?
Fyi, I am using PHP 5.6.3 and MySQL version 5.6.28-76.1-log with Apache server. When upgrading from ATutor 2.2.1 to 2.2.2, all system requirements checked are marked "Good". Sorry for such a long message. Again, thanks for your support and patience.
Posted: 2017-04-02 02:48:52
danghoaiphuc
Subject: Re: Vietnamese language pac ATutor 2.2.2 Issue Solved ManuallyQuote this post in your reply
Hi Greg,
Finally, I figure out the issue. The system automatically generates more \\ signs than it's supposed to be. I don'am not sure that's caused by ATutor translation terminal or by my databae system. I must manually remove extra "\" signs and it works perfect. So now feel better to finish the Vietnamese lang pack for ATutor 2.2.2. Hopefully, would post here the completion in few days. Seems not many strings translated so far since our work in 2005 and got many error conversions from between ansi/utf-8 for the current language pack. It results unicode characters in question mark sign. Thanks.
Posted: 2017-04-02 07:24:32
 
Page: 1

You must be signed-in to post.

Related Articles