Community Forums

ATutor Support

SCORM: disappeared "settings" link


You must be signed-in to post.

AuthorSubject
 
Page: 1
nerilab
scorm_error.jpg

Attachment: scorm_error.jpg
Subject: SCORM: disappeared "settings" linkQuote this post in your reply
Hi all;

i have imported some Scorm packages
( one downloaded from ATutor website too - UNITED NATION )
into ATutor through Scorm module, but the link to "Settings.php"
( Manage - Scorm Packages - near Delete Packages and Import Packages )
in Packages page does not exist...it has been repleced by : "[_]", and when
cliccking on it I receive back this message from ATutor:

"The following errors occurred:
Page cannot be found. " ...

I have verified that setting.php file exists in appropriate directory.

I have also included little screenshot.

Please, could You help me resolve this?
Thank You so much in advance

Marco
------------------------


Things to describe:
operating system - Linux apollo.hagenhosting.com 2.6.18
version of ATutor - 1.5.3.3pl1
versions of php - PHP Version 5.2.0
version of mysq l - 5.0.27
webserver & version - Apache/2.2.3 (Unix) FrontPage/5.0.2.2635 PHP/5.2.0
copies of error messages -
changes to default settings -
web browser being used -
and anything else relevant -
Posted: 2007-03-29 02:56:16
vegard

Avatar for vegard
Subject: Re: SCORM: disappearedQuote this post in your reply
I can confirm this bug, and have reported it before:

www.atutor.ca/view/3/9293/1.html

see post 8 and down (does not resolve it though..)
Posted: 2007-03-29 03:22:02
nerilab
Subject: Re: SCORM: disappearedQuote this post in your reply
Hi Vegard, thanks - but where I can find the new version of scorm package module??

Thank You

Marco
Posted: 2007-03-29 03:37:40
vegard

Avatar for vegard
Subject: Re: SCORM: disappearedQuote this post in your reply
sorry no, your module is probably just fine smile

I still believe this is a bug in Atutor, but what Joel & Greg are saying in the other thread is that this is a bug in the SCORM package used (it isn't, though).

the bug is present in the demo versions of both ATutor 1.5.3. and 1.5.4 at the atutor site.
Posted: 2007-03-29 04:16:09
nerilab
Subject: Re: SCORM: disappearedQuote this post in your reply
Thank You, Vegard.

I also believe it is a bug of ATutor:
indeed I installed an example scorm package I downloaded just from ATutor website, to verify this matter, and It does not work anyway

Thank You for Your Kind help
Best

Marco
Posted: 2007-03-29 04:40:06
greg

Avatar for greg
Subject: Re: SCORM: disappearedQuote this post in your reply
I'm not sure what you're both doing, but the packages (i.e. SCOs) import and display fine. I just imported the United Nations package into the demo154 site and the demo for 1.5.3, and had no trouble with either.

Java JRE 1.5 is required. Packages won't run if you are using the old 1.4 JREs.
Posted: 2007-03-29 08:38:33
greg

Avatar for greg
Subject: Re: SCORM: disappearedQuote this post in your reply
If you attach the SCO here, we will look at it.
Posted: 2007-03-29 08:39:33
nerilab
QuizAtutortest.zip

Attachment: QuizAtutortest.zip
Subject: Re: SCORM: disappearedQuote this post in your reply
Hi Greg, thank You - but:

I'm sure about what I have written:

www.atutor.ca/atutor/demo154/tools/packages/index.php

If You go at the address linked above with demo/demo user/password, You will find that the "settings.php" links does not work.

Anyway, in attachment the SCO

Thank You
Best

Marco



Things to describe:
operating system -
version of ATutor -
versions of php -
version of mysq l -
webserver & version -
copies of error messages -
changes to default settings -
web browser being used -
and anything else relevant -
Posted: 2007-03-29 08:56:37
vegard

Avatar for vegard
scormsettings.jpg

Attachment: scormsettings.jpg
Subject: Re: SCORM: disappearedQuote this post in your reply
hi greg,

all SCOs run fine (I've never said anything else) - the problem is still that there's a phantom link to tools/packages/settings.php when you're at manage -> packages.

see attached screendump from your demo server.
Posted: 2007-03-30 03:06:29
greg

Avatar for greg
Subject: Re: SCORM: disappearedQuote this post in your reply
Got it. Its been added to the bug tracker.
Posted: 2007-03-30 08:35:52
guyh

Avatar for guyh
Subject: Re: SCORM: disappearedQuote this post in your reply
Hi all / Nerilab,
I have found 'phantom' links in the SCORM and ecomm modules and these are generally caused by faults in each modules module.php file.

The problems stem from 2 causes - if the file paths are incorrect or missing for the child links or in two instances of the SCORM mosdule on line 30&31 they are commented out.
Posted: 2007-04-08 03:27:59
 
Page: 1

You must be signed-in to post.

Related Articles