Community Forums

ATutor Support

Problems with e-mails from create_course_list.php


You must be signed-in to post.

AuthorSubject
 
Page: 1
vegard

Avatar for vegard
Subject: Problems with e-mails from create_course_list.phpQuote this post in your reply
We're experiencing some problems with confirmation e-mails from the system:

*When* creating new users from the enrollment -> create course list feature, no e-mails are sent. I've asked our server admins for the log entries, and they say there are no entries for the adresses we have tried with. From the other functions described below, there are entries. So it seems there's an error somewhere in Atutor, causing e-mails to not be sent when using this function, at least at our server.

I've tried all the other e-mailing functions in Atutor, and they all work fine. If I add a user to a course from the enrollment -> Alumni / Not enrolled tabs, they get the e-mail. The forgotten pasword function works, message notifications by e-mail and forums subscruptions work, and if you add a user from admin -> users -> create user account it also works. I've used the same user / e-mail address in all tests, so there's nothing wrong there.

First, anyone else experiencing this? Can anyone confirm? I know it used to work earlier.

Also, I've tried to inspect the code, but my knowledge to php is limited. However, /password_reminder.php and admin/create_user.php calls the AtutorMailer function to do this, which works.

in /enrollment/index.php (for the Alumni / Not Enrolled users) I cannot find this function, but the file requires the /include/html/enrollment.inc.php file, and this works.

In /enrollment/create_course_list.php, where the problem's at, I cannot find the function either, but the the form data is sent along to /enrollment/verify_list.php, which requires the file /include/lib/enroll.php, where I find the AtutorMailer function.

...soo, here it stops for me, but I believe the only file that is unique for the create_course_list.php may be the verify_list.php - so maybe this is where something happens?
Posted: 2007-12-03 05:04:05
greg

Avatar for greg
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
I just tried it with the instructor create course list feature and it seems to work fine.

We're too tied up with release preparation to investigate this further right now. If you want to try to track down the problem (if it is an ATutor problem), and post a solution we'll try top get it added before the release.

If necessary, replace the offending files from the code repository.
Posted: 2007-12-03 09:05:25
jens

Avatar for jens
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
I have never used that service but tested it now to confirm the bug or not, on a third server setup.

I filled in the 3 textfields and clicked "Add to Course List" - no mail arrived at the adress

when clicking the "Add to Enrolled List" the mail is send immediately (I'm not using the croon hook).

so I guess I was wrong expecting a mail to be sent at step 1 but it came through fine at step 2.
Hope it can be of some help in further debugging.

Things to describe:
operating system - FreeBSD 6.2
version of ATutor - 1.5.5
versions of php - 5.2.4
version of mysq l - 5.0.45
webserver & version - Apache 1.3
copies of error messages -
changes to default settings -
web browser being used -
and anything else relevant -

In reply to:
*When* creating new users from the enrollment -> create course list feature, no e-mails are sent.

Posted: 2007-12-03 13:45:08
vegard

Avatar for vegard
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
thanks, I've kind of figured it out now, I think it was a combination of:

a) user feedback a-la "crisis!! nobody gets their login information!!" which rather should be "one or two persons didn't get their login information"

b) black magic

c) Atutor not behaving the way I expected it to.

concerning c, if you add a user through enrollment -> "create course list" whose account allready exist you get the message "OK - account exists", and the user is enrolled, but no e-mail is sent to this user to notify him / her about the new enrollment. if you would have enrolled the same user through the "not enrolled" tab this mail would have been sent.

we typically tell our instructors to use the create course list feature, as it is intuitive and easy to use. however, existing accounts that gets enrolled in a course using this feature should also get an "Course enrollment approved" e-mail from the system! consider that a feature request smile
Posted: 2007-12-04 05:27:51
IndieRect

Avatar for IndieRect
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
Nice said. happy

In reply to:
... I think it was a combination of:

a) user feedback a-la "crisis!! nobody gets their login information!!" which rather should be "one or two persons didn't get their login information"

b)...

Posted: 2007-12-04 05:42:16
greg

Avatar for greg
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
I have been able to reproduce the problem now. When creating a course list, people who are already in the system do not receive the usual enrolment notice.

It should now be fixed, and show up in tonight's build.
Posted: 2007-12-04 11:07:03
vegard

Avatar for vegard
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
great Greg, thanks!
Posted: 2007-12-04 11:37:54
vegard

Avatar for vegard
Subject: Re: Problems with e-mails from create_course_list.phpQuote this post in your reply
BTW: the same is also the case when you enroll users as admin -> users -> [a user] -> enrollment -> mark, enroll in new courses.

I don't know if this was automatically fixed when you fixed the same issue when doing this in the course list?
Posted: 2007-12-14 09:10:05
 
Page: 1

You must be signed-in to post.

Related Articles