Community Forums

ATutor Support

Error message during Version 2.2 upgradel


You must be signed-in to post.

AuthorSubject
 
Page: 1
skappes

Avatar for skappes
ATutorUpgrade2.2Error.pdf
Subject: Error message during Version 2.2 upgradelQuote this post in your reply
I just upgraded my ATutor version 2.1 to ATutor-2.2-RC1 that I downloaded today. During the installation I got error messages after Step 3 but was able to continue. The messages are attached (with login credential info removed). I haven't tested it much but the upgrade does appear to have worked.

Sandie

Database server
• Server: Localhost via UNIX socket
• Server type: Percona Server
• Server version: 5.5.32-31.0-log - Percona Server (GPL), Release rel31.0, Revision 549
• Protocol version: 10
Web server
• cpsrvd 11.42.1.16
• Database client version: libmysql - 5.0.96
• PHP extension: mysqli
• PHP 5.3.28
Posted: 2014-07-22 12:27:31
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
Thanks for the report.

You should hold off upgrading production sites until the final release. Though the current RC1 is relatively stable, there have been a few changes since it was released, and there will likely be a few more.

We're investigating this particular problem now.
atutor.ca/atutor/mantis/view.php?id=5495
Posted: 2014-07-22 12:39:11
skappes

Avatar for skappes
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
I'm just testing 2.2 on a copy of my production site. My site has a custom theme and some source code customization so it takes me a while to figure out how a new version impacts them. I never got the time to upgrade to 2.1.1 so am hoping to get things figured out early so I can upgrade to 2.2 soon after it is released.
Posted: 2014-07-22 14:15:55
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
Some progress with this. Theres a temporary work around, but not a full solution yet. See the comments:

www.atutor.ca/atutor/mantis/view.php?id=5495
Posted: 2014-07-24 20:54:18
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
We've tracked this issue down to a problem with mysql version 5.1.66, and perhaps earlier versions. There was a bug fix in the following version that corrects the issue of backticks/backquotes used in queries. There does not appear to be a reasonable workaround, other than commenting out lines 459-474 to remove the UTF-8 check, or upgrading to a newer version of mysql.

For details on the bug, search the following page for "backtick"

dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-67.html [^]
Posted: 2014-07-25 14:28:32
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
A work around is to comment out the following block of code

https://github.com/atutor/ATutor/blob/master/include/install/install.inc.php#L460-L474
Posted: 2014-08-25 07:39:26
amboycharlie
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
All kinds of things are going wrong for me with this upgrade. I am shifting back to 2.1.

I noticed that godaddy server's default php was 5.3 but mine was set at 5.2. I was able to upgrade to 5.4. The mysql however is 5.0., so that also may be the source of my trouble.
Posted: 2014-09-03 05:33:35
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
Sorry for the trouble. We've not been able to reproduce the problem. The php/mysql versions you mention should be okay. Will investigate if you want to share your ATutor and Godaddy login details. I'm curious why Godaddy has problem with ATutor 2.2

info at atutor dot ca
Posted: 2014-09-03 07:14:01
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
An updated bundle of ATutor 2.2 has been released, replacing the old version on Sourceforge. It will correct the errors generated when tables are ALTERed during the upgrade process.
Posted: 2014-09-20 12:16:25
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
We've made some adjustments to the installer, which we're hoping will resolve the real_escape_string() error people have been experiencing. Can you test it on the server that was producing the error and let us know how it goes.

atutor.ca/atutor/files/ATutor-2.2-test.tar.gz
Posted: 2014-10-04 13:50:59
greg

Avatar for greg
Subject: Re: Error message during Version 2.2 upgradelQuote this post in your reply
atutor.ca/atutor/files/ATutor-2.2-test.tar.gz
Posted: 2014-10-04 13:55:49
 
Page: 1

You must be signed-in to post.

Related Articles