Community Forums

ATutor Support

After upgrading to ATutor 2.2


You must be signed-in to post.

AuthorSubject
 
Page: 1
HenryGR
Subject: After upgrading to ATutor 2.2Quote this post in your reply
Just upgraded to version 2.2 from version 2.1 where everything was running smoothly. No, as soon as I log in (as administrator) I get an error message:

*****************
The following errors occurred:

ATutor was unable to access the database. If the problem persists, please report this to an Administrator with this date reference (09/19/2014 07:13:42 pm)
****************

No changes on configuration can be performed, although the users can log in correctly. javascript:smilie('frown')

My config shows:
Database:
8.30 MB
Disk Usage:
56.52 MB
Courses:
13
Users:
82
ATutor Version:
2.2(unknown - 2014-09-19 19:13:42). Check Latest Version.
PHP Version:
5.3.29-1~dotdeb.0
MySQL Version:
5.5.38-1~dotdeb.0
OS:
Linux 2.6.32-5-686 frown
Posted: 2014-09-19 14:16:49
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
There's been a couple reports of issues upgrading from ATutor 2.1, thoguh so far we've not been able to reprodcue the problem. I've added the issue to the tracker.

Will take another look as soon as we can.

Follow at:
atutor.ca/atutor/mantis/view.php?id=5536

If you can get to the PHP error log, you could help by posting any error message generated there when the database error shows in ATutor
Posted: 2014-09-19 14:42:18
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
An updated bundle of ATutor 2.2 has been released, replacing the old version on Sourceforge. It will correct the errors generated when tables are ALTERed during the upgrade process.

Was it 2.1, or was it actually 2.1.1 that you upgraded from?
Posted: 2014-09-20 12:15:48
HenryGR
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
Hi Greg,
Really I am tempted to sat it was 2.1.1 but, just to double check, how can I find that? Of course I have a full backup of the ATutor directory, can I inspect any file?
frown
Posted: 2014-09-23 13:36:12
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
Look in

include/lib/constants.inc.php
Posted: 2014-09-23 13:59:01
HenryGR
constants.inc.php
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
OK, so I was wrong. It was 2.1
Please find the file attached, may it be of any help ;-)
as I am not able to get the PHP error log.
Posted: 2014-09-23 14:09:57
HenryGR
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
Greg,
should I re install ATutor? or re-upgrade version 2.2?
tongue
Posted: 2014-09-26 03:40:06
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
Download again and reinstall
Posted: 2014-09-26 08:21:02
HenryGR
ATutorUpgradeError.png
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
Hi Greg,
after re-downlod and re-upgrade attemp, I get an error on step number 2 (image dump attached) allrhough I have doublecheck the db user to have ALL privileges. :-(
Posted: 2014-09-27 06:42:00
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
It would appear you are using an old ATutor-2.2 bundle. The problem in the image you attached was addressed in the latest bundle.

You can check the file that was changed by comparing the version on GitHub with the version you have.

https://github.com/atutor/ATutor/commit/c62d8393342c8875152ea2ebf2ad0bbc148215e3
Posted: 2014-09-27 09:16:48
uuganbayar
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on - Oracle linux 7 64bit
ATutor version - 2.2
Patch #s applied -
ATutor theme name -
PHP version - 5.4.32
MySQL version - 5.6.21
Webserver & version - apache 2.4.6
Copies of error messages - PHP Fatal error: Call to a member function real_escape_string() on a non-object in /var/www/html/ATutor22/include/lib/mysql_connect.inc.php on line 141

After last release 2.2 download include/classes/sqlutility.class.php check file changed compare ok.
Posted: 2014-09-30 21:42:54
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
We are aware of the issue, but have been unable to reproduce it ourselves. No fix is available yet.
Posted: 2014-10-02 09:18:20
greg

Avatar for greg
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
We've made some adjustments to the installer, which we're hoping will resolve the real_escape_string() error people have been experiencing. Can you test it on the server that was producing the error and let us know how it goes.

atutor.ca/atutor/files/ATutor-2.2-test.tar.gz
Posted: 2014-10-04 13:49:18
urvishpatel15
Untitled.png
Subject: Re: After upgrading to ATutor 2.2Quote this post in your reply
If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on - windows 8.1
ATutor version - 2.2
Patch #s applied -
ATutor theme name -
PHP version -
MySQL version -
Webserver & version -
Copies of error messages -
Changes to default settings -
Web browser being used -
...and anything else relevant -
frown
Posted: 2015-07-23 12:59:29
 
Page: 1

You must be signed-in to post.

Related Articles