Community Forums

ATutor Support

Cannot install Atutor past step 2


You must be signed-in to post.

AuthorSubject
 
Page: 1 | 2
greg

Avatar for greg
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
Where did you download ATutor from?

And, when you uploaded to the server, did you upload the bundle and unzip on the server, or unzip first and upload file by file?

Are you hosting on provider (ISP), if so which one?

In reply to:
Ahhh, I lied. It appeared to go thru the process, but nothing was written to the database. Now I can't even reinstall it, so I have to restart the process.

Guilio


If you are asking for help,...

Posted: 2014-10-03 09:01:53
Benie1234
Subject: my Thread?Quote this post in your reply
As this was my thread I have still not received an answer?
Posted: 2014-10-03 09:11:38
ggaspero
Subject: Re: my Thread?Quote this post in your reply
@Benie1234 - sorry, didn't mean to hijack your thread... i thought his advice might help you too as it seemed like we had the same issue.

@greg - i guess you didn't read my original post regarding my hosting. it is hosted on a shared server at dreamhost.com. it uploaded the compressed file, then unzipped it through my shell account



If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on -
ATutor version -
Patch #s applied -
ATutor theme name -
PHP version -
MySQL version -
Webserver & version -
Copies of error messages -
Changes to default settings -
Web browser being used -
...and anything else relevant -
Posted: 2014-10-03 09:31:35
greg

Avatar for greg
Subject: Re: my Thread?Quote this post in your reply
And ggaspero where did you download ATutor from?

I'm trying to eliminate variables, to try and track down which one is causing this issue.
Posted: 2014-10-03 09:49:43
greg

Avatar for greg
Subject: Re: my Thread?Quote this post in your reply
@Benie1234 if you behave, we'll try to help you too. Misbehave and you'll be banned.

In reply to:
As this was my thread I have still not received an answer?

Posted: 2014-10-03 09:50:14
ggaspero
Subject: Re: my Thread?Quote this post in your reply
Downloaded directly from your site...

www.atutor.ca/atutor/download.php




====
If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on -
ATutor version -
Patch #s applied -
ATutor theme name -
PHP version -
MySQL version -
Webserver & version -
Copies of error messages -
Changes to default settings -
Web browser being used -
...and anything else relevant -
Posted: 2014-10-03 10:21:09
Benie1234
Subject: Re: my Thread?Quote this post in your reply
I only stated that this problem is not confined to a couple of posts on here.

the support desk at UK2.net and godaddy both have records from others who have had problems. Thy refer to a previosu thread on here which was also not answered.

I know how hard it is to sort out issues but trying to blame users who have many years experience with SQL-databases is not helpful

Regards

Bernie
Posted: 2014-10-03 10:35:58
greg

Avatar for greg
Subject: Re: my Thread?Quote this post in your reply
Blame users? Let be constructive here, instead of dis'ing the people trying to help.

As I said, this is going to require someone who experiencing the problem to help resolve. There's not a lot we can do if we can't reproduce the problem.

If you have many years of SQL-database experience, then help us identify where the problem is occurring.
Posted: 2014-10-03 10:52:54
ggaspero
Subject: Re: my Thread?Quote this post in your reply
So, at this point, I went into the include/install/db directory and opened the atutor_install.sql file, copied the file and created the tables thru phpMyAdmin. I now have all the tables setup this way.

Not sure if that will help or not.

Guilio




If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on -
ATutor version -
Patch #s applied -
ATutor theme name -
PHP version -
MySQL version -
Webserver & version -
Copies of error messages -
Changes to default settings -
Web browser being used -
...and anything else relevant -
Posted: 2014-10-03 13:30:00
Benie1234
Subject: hand installedQuote this post in your reply
Hi Guilio,

Yes I got it hand installed as well.........I guess this proves there is no problems with our set ups the problem exists in the install PHP codes.....It looks like the way its making calls to the sql server is getting rejected.

You need to check after you hand install that the datbase is protected and not open to SQL injection attack. My guess so far is that they have made recent modifications to protect against this and this may be the root of the issue.

good luck with using atutor
Posted: 2014-10-04 02:36:15
greg

Avatar for greg
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
I know you've managed to install manually. Could you test the bundle linked below on the server that was producing the error to see if it installs. Let me know how it goes.

atutor.ca/atutor/files/ATutor-2.2-test.tar.gz

In reply to:
Ahhh, I lied. It appeared to go thru the process, but nothing was written to the database. Now I can't even reinstall it, so I have to restart the process.

Guilio

Posted: 2014-10-04 13:47:00
ggaspero
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
Greg

That worked! And, I was even able to log in after the install!

It shows I have 4 patches available upon logging in as the ADMIN.

Thanks!
Guilio




If you are asking for help, provide lots of detail so problems can be reproduced.

Things to describe:
Operating system ATutor is installed on -
ATutor version -
Patch #s applied -
ATutor theme name -
PHP version -
MySQL version -
Webserver & version -
Copies of error messages -
Changes to default settings -
Web browser being used -
...and anything else relevant -
Posted: 2014-10-04 14:17:47
ggaspero
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
Got it installed, added the patches, then went to ADD MODULES, and got this error:

Warning: in_array() expects parameter 2 to be array, string given in /home/fpreports/fpreports.com/training/themes/default/admin/modules/install_modules.tmpl.php on line 134

42 times....

Guilio
Posted: 2014-10-04 18:12:12
greg

Avatar for greg
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
We've noted the issue, and will investigate soon.

www.atutor.ca/atutor/mantis/view.php?id=5542


Please start a new thread when the topic changes.
Posted: 2014-10-05 10:09:12
greg

Avatar for greg
Subject: Re: Cannot install Atutor past step 2Quote this post in your reply
Patch 0005 for ATutor 2.2 has been posted to resolve the long list of error messages. Use the admin's Patcher to apply the patch.

In reply to:
Got it installed, added the patches, then went to ADD MODULES, and got this error:

Warning: in_array() expects parameter 2 to be array, string given in /home/fpreports/fpreports.com/training/themes...

Posted: 2014-10-12 12:07:26
 
Page: 1 | 2

You must be signed-in to post.

Related Articles