Community Forums

ATutor Support

glossary and html


You must be signed-in to post.

AuthorSubject
 
Page: 1
chipwiegand
331201785028PM.png

Attachment: 331201785028PM.png
Subject: glossary and htmlQuote this post in your reply
Please correct me if I am wrong: it appears html markup is not allowed in glossary entries, correct?
Also, when I edit a glossary entry there are html breaks inserted by atutor, if I leave those and just click on save, or edit and click on save (leaving the break entities) the glossary entry will be broken. All the text will be in one long line, no line breaks of any kind.
This means that I must delete the glossary entry and create a new one with the desired new edits.
I hope this makes sense. I've a screenshot that shows each step of the process and the results.

Operating system ATutor is installed on -
ATutor version -2.2.2
Patch #s applied -0001, 0002, 0003, 0005, 0006, 0007, 0008
ATutor theme name - ATutor Classic
PHP version -5.4.45
MySQL version -5.6.33-cll-lve
Webserver & version - Linux 2.6.32-673.26.1.lve1.4.20.el6.x86_64
Web browser being used - Chrome
Posted: 2017-03-31 21:51:12
greg

Avatar for greg
Subject: Re: glossary and htmlQuote this post in your reply
Thanks for pointing out the line break problem in glossary items. I've made a note in the bug tracker. It'll be a few weeks before I can get to it.

www.atutor.ca/atutor/mantis/view.php?id=5780

It sounds like the glossary editor is missing the hemlspecialchar_decode() to turn the entities after saving, back into HTML when opened in the editor.

Honestly I do not remember whether glossary items can have HTML in them. Seems to me, no.

If you are able to fix it yourself, we'd be happy to take a pull request on github to fix the problem.
Posted: 2017-03-31 23:36:11
 
Page: 1

You must be signed-in to post.

Related Articles